ViewBox conversion

Developer
Jan 23, 2009 at 12:54 AM
Hi all,

I'm using XamlTune for Adobe Illustrator -> XAML conversion, and I've fixed a few glitches I ran into along the way.  (Two patches submitted.)

I'm now facing some major conversion glitches stemming from incorrect handling (or non-handling) of the SVG viewBox attribute.

As I delve into the code, I find that somehow has attempted to add support for the viewBox attribute in the past, but the support is presently not actually used.  Or am I missing something?

The short of it is, I am willing to spend time trying to resuscitate the viewBox support, but am wondering if anyone else has any comments on previous attempted implementations thereof, problems encountered in the process, etc, etc?

P.S. XamlTune is cool and very helpful, and for the line art I am converting, it seems to be the best conversion tool around.  Lovit!  :)  Massive kudos to those who have gotten it to this point.



Jonathan Field
Melbourne, Australia
Coordinator
Jan 23, 2009 at 11:56 PM
Does that mean you're working on a .ai -> svg file conversion?  If so that will be so cool.  Let me know if you don't hear back from Titaye and I can get your patches checked in.

I'm sorry, but I don't know anything about the viewbox code.

Bryan
Coordinator
Jan 23, 2009 at 11:59 PM
I found the patches you've uploaded.  I'll take a look at them soon.

Bryan
Coordinator
Jan 28, 2009 at 9:46 PM
Those patches look good so far.  Could you send some test images for them so that I can see them working and so that we can have them around for regression testing?

Thanks.

Bryan
Developer
Jan 28, 2009 at 9:52 PM
Sure. Do they need to be in any particular format to assist with automated testing, or should I just send an SVG with some text notes describing what we should see on successful conversion?
Thanks,
Jonathan Field


From: LoneCoder [mailto:notifications@codeplex.com]
Sent: Thursday, 29 January 2009 8:47 AM
To: jonathan@relativesystems.com
Subject: Re: ViewBox conversion [XamlTune:45010]

From: LoneCoder

Those patches look good so far. Could you send some test images for them so that I can see them working and so that we can have them around for regression testing?

Thanks.

Bryan
Coordinator
Mar 29, 2009 at 4:53 PM
Hello Jonathan,

I finally applied the patches that you sent in.  Thanks for your contribution.

I've become a coordinator for the project now and have added you to the project as a developer.  Please feel free to commit any more improvements you might make.

Bryan